I have just installed a new fresh Debian Etch, and this time when I tried to install VMware server on it following my own instructions I could not, I am now using vmware server 1.0.3, There was not need to patch it in order to have it installed and running, but as soon as I tried to browse the directory to open a VM I got this error.

(vmware:10110): libgnomevfs-WARNING **: Cannot load module /usr/lib/gnome-vfs-2.0/modules/libfile.so' (/usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1: version GCC_4.2.0’ not found (required by /usr/lib/libstdc++.so.6))

Googling a little I have found that if you issue this command in your terminal

export VMWARE_USE_SHIPPED_GTK=yes

and then run

vmware &

the problem go away, but this time you will be using another graphical interface, a little bit slower than the original, hope this can help somebody.