Today I upgraded my Linux from Etch to Lenny, and one of the first things that stop working was vmware-server, actually I did not expect it to work at all.

Well to fix that I run ./vmware-config.pl as root This is the error I got:

Your kernel was built with "gcc" version "4.1.3", while you are trying to use 
"/usr/bin/gcc" version "4.2.3". This configuration is not recommended and 
VMware Server may crash if you'll continue. Please try to use exactly same 
compiler as one used for building your kernel. Do you want to go with compiler 
"/usr/bin/gcc" version "4.2.3" anyway? [no]

After reading some different ways to fix this problem I found this one, and it worked great.

first execute:

ls -l /usr/bin/gcc*

to see which versions you have installed, this is my output

lrwxrwxrwx 1 root root     16 2007-12-05 16:21 /usr/bin/gcc -> /usr/bin/gcc-4.2
-rwxr-xr-x 1 root root 204836 2007-10-19 11:38 /usr/bin/gcc-4.1
-rwxr-xr-x 1 root root 192532 2007-10-14 11:49 /usr/bin/gcc-4.2
-rwxr-xr-x 1 root root  16312 2007-10-19 11:31 /usr/bin/gccbug-4.1
-rwxr-xr-x 1 root root   2018 2007-04-08 21:57 /usr/bin/gccmakedep

As you may see I have 4.1 and 4.2 versions installed but my gcc command is linked to 4.2, to solve that just enter these commands.

su -

export CC=/usr/bin/gcc-4.1

and then

vmware-config.pl

everything run o.k. this time.