Hi, I have just upgraded from Debian Lenny to Debian Squeeze, and so far so good, everything is working great as I am used to since I start using Debian, when Etch was in testing.

Since then I have never reinstalled my Debian machine, I have installed Etch Testing that day, and then upgraded to Lenny and now to Squeeze, I have even change the machine and only disconnect the disk from the old one and connect it to the new one, and everything continue to work the same, let me tell you that is not a server and it is my Desktop PC.

I have installed there Gnome, XFCE, Openbox, Fluxbox and a lot of other software, like skype, opera, Open Office, Firefox, Thunderbird, and lots of tools.

As for the server applications I am running pdnsd as my personal DNS server and polipo as my personal web server, I also have installed there apt-cache because I also have Debian in my Laptop and do not want to download the same files twice.

It has been a great experience all this time with Debian, I have never has any problem of system halted, nor even an application halted, so I can say that at least for Desktop application Debian testing is stable.

It must be said that you can not count with the latest software if you are with Debian, but usually you don’t need it.

I have a dual boot with two Linux or even triple boot, where I have Debian, Crunchbang Linux and Gentoo Linux, that way I may have the latest software and learn about Linux.

I think I will stay as a Debian user for a long time.

[Update - 17/02/2009]

I will add here the packages that were updated when I switch from Lenny to Squeeze

===============================================================================
[REMOVE, NOT USED] djvulibre-desktop
[REMOVE, NOT USED] libboost-filesystem1.34.1
[REMOVE, NOT USED] ttf-dustin
[INSTALL, DEPENDENCIES] libasn1-8-heimdal
[INSTALL, DEPENDENCIES] libdjvulibre-text
[INSTALL, DEPENDENCIES] libgssapi2-heimdal
[INSTALL, DEPENDENCIES] libheimntlm0-heimdal
[INSTALL, DEPENDENCIES] libhx509-3-heimdal
[INSTALL, DEPENDENCIES] libkrb5-25-heimdal
[INSTALL, DEPENDENCIES] libroken18-heimdal
[INSTALL, DEPENDENCIES] libsox1
[INSTALL, DEPENDENCIES] libwind0-heimdal
[INSTALL, DEPENDENCIES] python-reportlab-accel
[INSTALL, DEPENDENCIES] xfonts-terminus
[REMOVE, DEPENDENCIES] libsox0
[UPGRADE] alacarte 0.11.5-1 -> 0.11.6-1
[UPGRADE] apt-cacher 1.6.4 -> 1.6.7
[UPGRADE] avahi-daemon 0.6.23-3lenny1 -> 0.6.23-4
[UPGRADE] avahi-utils 0.6.23-3lenny1 -> 0.6.23-4
[UPGRADE] bsd-mailx 8.1.2-0.20071201cvs-3 -> 8.1.2-0.20081101cvs-2
[UPGRADE] cdrdao 1:1.2.2-16 -> 1:1.2.2-17
[UPGRADE] checkpolicy 2.0.16-1 -> 2.0.16-3
[UPGRADE] clusterssh 3.22-2 -> 3.24-1
[UPGRADE] conky 1.6.0-2 -> 1.6.1-1
[UPGRADE] cpio 2.9-13 -> 2.9-14
[UPGRADE] cpp-4.3 4.3.2-1.1 -> 4.3.3-3
[UPGRADE] debhelper 7.0.15 -> 7.0.17
[UPGRADE] debianutils 2.30 -> 2.31
[UPGRADE] dialog 1.1-20080316-1 -> 1.1-20080819-1
[UPGRADE] dictionaries-common 0.98.12 -> 0.98.16
[UPGRADE] dvd+rw-tools 7.1-3 -> 7.1-4
[UPGRADE] elinks 0.11.4-3 -> 0.12~pre2.dfsg0-1
[UPGRADE] elinks-data 0.11.4-3 -> 0.12~pre2.dfsg0-1
[UPGRADE] eterm 0.9.5-1 -> 0.9.5-2
[UPGRADE] evince 2.22.2-4~lenny1 -> 2.22.2-4
[UPGRADE] fastjar 2:0.95-4 -> 2:0.97-3
[UPGRADE] feh 1.3.4.dfsg.1-1 -> 1.3.4.dfsg.1-3
[UPGRADE] file 4.26-1 -> 4.26-2
[UPGRADE] fluxbox 1.0.0+deb1-8 -> 1.1.1-1
[UPGRADE] foomatic-gui 0.7.9.1 -> 0.7.9.2
[UPGRADE] g++-4.3 4.3.2-1.1 -> 4.3.3-3
[UPGRADE] gcc-4.3 4.3.2-1.1 -> 4.3.3-3
[UPGRADE] gcc-4.3-base 4.3.2-1.1 -> 4.3.3-3
[UPGRADE] gdm 2.20.7-4 -> 2.20.7-5
[UPGRADE] gdm-themes 0.6.1 -> 0.6.2
[UPGRADE] gettext 0.17-4 -> 0.17-6
[UPGRADE] gettext-base 0.17-4 -> 0.17-6
[UPGRADE] ghostscript 8.62.dfsg.1-3.2lenny0 -> 8.63.dfsg.1-2
[UPGRADE] ghostscript-x 8.62.dfsg.1-3.2lenny0 -> 8.63.dfsg.1-2
[UPGRADE] gnome-netstatus-applet 2.12.1-2 -> 2.12.2-1
[UPGRADE] gparted 0.3.8-1+b1 -> 0.3.9-3
[UPGRADE] gpicview 0.1.9-4+lenny1 -> 0.1.11-1
[UPGRADE] gs-common 8.62.dfsg.1-3.2lenny0 -> 8.63.dfsg.1-2
[UPGRADE] gs-esp 8.62.dfsg.1-3.2lenny0 -> 8.63.dfsg.1-2
[UPGRADE] gsfonts 1:8.11+urwcyr1.0.7~pre44-3 -> 1:8.11+urwcyr1.0.7~pre44-4
[UPGRADE] gstreamer0.10-esd 0.10.8-4.1~lenny1 -> 0.10.8-4.1
[UPGRADE] gstreamer0.10-plugins-good 0.10.8-4.1~lenny1 -> 0.10.8-4.1
[UPGRADE] hal-info 20080508+git20080601-1 -> 20081219-1
[UPGRADE] hardinfo 0.4.2.3-4 -> 0.4.2.3-5
[UPGRADE] iftop 0.17-8 -> 0.17-10
[UPGRADE] imagemagick 7:6.3.7.9.dfsg1-3~lenny1 -> 7:6.3.7.9.dfsg1-3
[UPGRADE] inkscape 0.46-2.lenny2 -> 0.46-5
[UPGRADE] iso-codes 3.5.1-1 -> 3.6-1
[UPGRADE] laptop-detect 0.13.6 -> 0.13.7
[UPGRADE] latex-beamer 3.07-1 -> 3.07-1.1
[UPGRADE] libarts1-akode 4:3.5.9-2 -> 4:3.5.9-3
[UPGRADE] libarts1c2a 1.5.9-2 -> 1.5.9-2+b1
[UPGRADE] libartsc0 1.5.9-2 -> 1.5.9-2+b1
[UPGRADE] libartsc0-dev 1.5.9-2 -> 1.5.9-2+b1
[UPGRADE] libavahi-client3 0.6.23-3lenny1 -> 0.6.23-4
[UPGRADE] libavahi-common-data 0.6.23-3lenny1 -> 0.6.23-4
[UPGRADE] libavahi-common3 0.6.23-3lenny1 -> 0.6.23-4
[UPGRADE] libavahi-compat-libdnssd1 0.6.23-3lenny1 -> 0.6.23-4
[UPGRADE] libavahi-core5 0.6.23-3lenny1 -> 0.6.23-4
[UPGRADE] libavahi-glib1 0.6.23-3lenny1 -> 0.6.23-4
[UPGRADE] libavahi-gobject0 0.6.23-3lenny1 -> 0.6.23-4
[UPGRADE] libavahi-qt3-1 0.6.23-3lenny1 -> 0.6.23-4
[UPGRADE] libboost-regex1.34.1 1.34.1-14 -> 1.34.1-15
[UPGRADE] libboost-signals1.34.1 1.34.1-14 -> 1.34.1-15
[UPGRADE] libcaca-dev 0.99.beta14-1 -> 0.99.beta16-1
[UPGRADE] libcaca0 0.99.beta14-1 -> 0.99.beta16-1
[UPGRADE] libcairo-perl 1.060-1 -> 1.060-2
[UPGRADE] libcairomm-1.0-1 1.6.0-1 -> 1.6.4-1
[UPGRADE] libcompress-raw-zlib-perl 2.012-1 -> 2.015-1
[UPGRADE] libcompress-zlib-perl 2.012-1 -> 2.015-1
[UPGRADE] libcucul-dev 0.99.beta14-1 -> 0.99.beta16-1
[UPGRADE] libcucul0 0.99.beta14-1 -> 0.99.beta16-1
[UPGRADE] libcurses-perl 1.23-1+b1 -> 1.27-1
[UPGRADE] libcurses-ui-perl 0.9605-1 -> 0.9607-1
[UPGRADE] libdaemon0 0.12-2lenny1 -> 0.13-2
[UPGRADE] libdb4.3 4.3.29-11 -> 4.3.29-12
[UPGRADE] libdb4.4 4.4.20-11 -> 4.4.20-12
[UPGRADE] libdb4.6 4.6.21-11 -> 4.6.21-13
[UPGRADE] libdjvulibre21 3.5.20-8+lenny1 -> 3.5.21-3
[UPGRADE] libept0 0.5.22 -> 0.5.26
[UPGRADE] libexempi3 2.0.1-1 -> 2.0.2-2
[UPGRADE] libgc1c2 1:6.8-1.1 -> 1:6.8-1.2
[UPGRADE] libgcc1 1:4.3.2-1.1 -> 1:4.3.3-3
[UPGRADE] libgcrypt11 1.4.1-1 -> 1.4.1-2
[UPGRADE] libgdbm3 1.8.3-3 -> 1.8.3-4
[UPGRADE] libgfortran3 4.3.2-1.1 -> 4.3.3-3
[UPGRADE] libgii1 1:1.0.2-2 -> 1:1.0.2-4
[UPGRADE] libgii1-target-x 1:1.0.2-2 -> 1:1.0.2-4
[UPGRADE] libgksu1.2-0 1.3.8-1 -> 1.3.8-2
[UPGRADE] libgksuui1.0-1 1.0.7-2 -> 1.0.7-3
[UPGRADE] libglade2-0 1:2.6.2-1 -> 1:2.6.3-1
[UPGRADE] libgnome2-0 2.20.1.1-1 -> 2.20.1.1-2
[UPGRADE] libgnome2-canvas-perl 1.002-1+b2 -> 1.002-2
[UPGRADE] libgnome2-common 2.20.1.1-1 -> 2.20.1.1-2
[UPGRADE] libgnomekbd-common 2.22.0-1 -> 2.22.0-2
[UPGRADE] libgnomekbd2 2.22.0-1 -> 2.22.0-2
[UPGRADE] libgnomekbdui2 2.22.0-1 -> 2.22.0-2
[UPGRADE] libgomp1 4.3.2-1.1 -> 4.3.3-3
[UPGRADE] libgpgme11 1.1.6-2 -> 1.1.8-2
[UPGRADE] libgpod3 0.6.0-6 -> 0.6.0-7
[UPGRADE] libgs8 8.62.dfsg.1-3.2lenny0 -> 8.63.dfsg.1-2
[UPGRADE] libgsf-1-114 1.14.8-1lenny2 -> 1.14.11-2
[UPGRADE] libgsf-1-common 1.14.8-1lenny2 -> 1.14.11-2
[UPGRADE] libgtksourceview-common 1.8.5-1 -> 1.8.5-2
[UPGRADE] libgtksourceview1.0-0 1.8.5-1 -> 1.8.5-2
[UPGRADE] libgtkspell0 2.0.13-1+b1 -> 2.0.13-2
[UPGRADE] libhsqldb-java 1.8.0.9-3 -> 1.8.0.10-1
[UPGRADE] libidn11 1.8+20080606-1 -> 1.10-3
[UPGRADE] libijs-0.35 0.35-3 -> 0.35-6
[UPGRADE] libimlib2 1.4.0-1.2 -> 1.4.2-4
[UPGRADE] libio-compress-base-perl 2.012-1 -> 2.015-1
[UPGRADE] libio-compress-zlib-perl 2.012-1 -> 2.015-1
[UPGRADE] libjack0 0.109.2-5 -> 0.116.1-3
[UPGRADE] libkeyutils1 1.2-9 -> 1.2-10
[UPGRADE] libkrb53 1.6.dfsg.4~beta1-5 -> 1.6.dfsg.4~beta1-6
[UPGRADE] liblapack3gf 3.1.1-1 -> 3.1.1-6
[UPGRADE] libmagic1 4.26-1 -> 4.26-2
[UPGRADE] libmagick++10 7:6.3.7.9.dfsg1-3~lenny1 -> 7:6.3.7.9.dfsg1-3
[UPGRADE] libmagick10 7:6.3.7.9.dfsg1-3~lenny1 -> 7:6.3.7.9.dfsg1-3
[UPGRADE] libmail-sendmail-perl 0.79-5 -> 0.79.16-1
[UPGRADE] libmailtools-perl 2.03-1 -> 2.04-1
[UPGRADE] libmodplug0c2 1:0.8.4-1 -> 1:0.8.4-3
[UPGRADE] libmpfr1ldbl 2.3.1.dfsg.1-2 -> 2.3.2.dfsg.1-1
[UPGRADE] libnfsidmap2 0.20-1 -> 0.21-2
[UPGRADE] libnss3-1d 3.12.0-5 -> 3.12.2.with.ckbi.1.73-1
[UPGRADE] liborbit2 1:2.14.13-0.1 -> 1:2.14.16-0.1
[UPGRADE] libqt4-assistant 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-core 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-dbus 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-designer 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-gui 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-help 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-network 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-opengl 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-qt3support 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-script 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-sql 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-sql-mysql 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-svg 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-test 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-webkit 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-xml 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqt4-xmlpatterns 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqtcore4 4.4.3-1 -> 4.4.3-2
[UPGRADE] libqtgui4 4.4.3-1 -> 4.4.3-2
[UPGRADE] librsvg2-2 2.22.2-2lenny1 -> 2.22.2-4
[UPGRADE] librsvg2-common 2.22.2-2lenny1 -> 2.22.2-4
[UPGRADE] libsensors3 1:2.10.7-1 -> 1:2.10.8-1
[UPGRADE] libsox-fmt-alsa 14.0.1-2+b1 -> 14.2.0-1
[UPGRADE] libsox-fmt-base 14.0.1-2+b1 -> 14.2.0-1
[UPGRADE] libspectre1 0.2.0.ds-1 -> 0.2.2.ds-1+b1
[UPGRADE] libstdc++6 4.3.2-1.1 -> 4.3.3-3
[UPGRADE] libstdc++6-4.3-dev 4.3.2-1.1 -> 4.3.3-3
[UPGRADE] libsuitesparse-3.1.0 3.1.0-3 -> 1:3.1.0-3.1
[UPGRADE] libtasn1-3 1.4-1 -> 1.5-1
[UPGRADE] libtasn1-3-bin 1.4-1 -> 1.5-1
[UPGRADE] libtidy-0.99-0 20080116cvs-2 -> 20081224cvs-1
[UPGRADE] liburi-perl 1.35.dfsg.1-1 -> 1.37+dfsg-1
[UPGRADE] libwpg-0.1-1 0.1.2-1 -> 0.1.3-1
[UPGRADE] libwww-perl 5.813-1 -> 5.820-1
[UPGRADE] libxml-twig-perl 1:3.32-1 -> 1:3.32-2
[UPGRADE] logrotate 3.7.1-5 -> 3.7.7-3
[UPGRADE] lynx 2.8.7dev9-2.1 -> 2.8.7dev13-1
[UPGRADE] lynx-cur 2.8.7dev9-2.1 -> 2.8.7dev13-1
[UPGRADE] lyx 1.5.5-1 -> 1.6.1-1
[UPGRADE] lyx-common 1.5.5-1 -> 1.6.1-1
[UPGRADE] mailx 1:20071201-3 -> 1:20081101-2
[UPGRADE] manpages 3.05-1 -> 3.17-1
[UPGRADE] mawk 1.3.3-11.1 -> 1.3.3-14
[UPGRADE] mpack 1.6-5 -> 1.6-6
[UPGRADE] mtr-tiny 0.73-1 -> 0.75-2
[UPGRADE] myspell-en-us 1:2.4.0-3 -> 1:2.4.0-4
[UPGRADE] nfs-common 1:1.1.2-6lenny1 -> 1:1.1.4-1
[UPGRADE] nitrogen 1.3-1 -> 1.4-1
[UPGRADE] nmap 4.62-1 -> 4.68-1
[UPGRADE] openoffice.org-thesaurus-en-us 1:2.4.0-3 -> 1:2.4.0-4
[UPGRADE] patchutils 0.2.31-4 -> 0.3.1-1
[UPGRADE] perlmagick 7:6.3.7.9.dfsg1-3~lenny1 -> 7:6.3.7.9.dfsg1-3
[UPGRADE] pidentd 3.0.19.ds1-4 -> 3.0.19.ds1-5
[UPGRADE] printconf 0.7.9.1 -> 0.7.9.2
[UPGRADE] python-apt 0.7.7.1+nmu1 -> 0.7.8
[UPGRADE] python-dbus 0.82.4-2 -> 0.83.0-1
[UPGRADE] python-foomatic 0.7.9.1 -> 0.7.9.2
[UPGRADE] python-reportlab 2.1dfsg-2 -> 2.2-2
[UPGRADE] python-support 0.8.4 -> 0.8.7
[UPGRADE] qt4-qtconfig 4.4.3-1 -> 4.4.3-2
[UPGRADE] rcconf 1.21 -> 2.0
[UPGRADE] resolvconf 1.42 -> 1.43
[UPGRADE] sed 4.1.5-6 -> 4.1.5-8
[UPGRADE] sox 14.0.1-2+b1 -> 14.2.0-1
[UPGRADE] synaptic 0.62.1+nmu1 -> 0.62.5
[UPGRADE] sysstat 8.1.2-2 -> 8.1.8-1
[UPGRADE] terminator 0.9-1.1 -> 0.12-1
[UPGRADE] texmaker 1.7.1-2 -> 1.8-1
[UPGRADE] tidy 20080116cvs-2 -> 20081224cvs-1
[UPGRADE] traceroute 2.0.11-2 -> 2.0.12-1
[UPGRADE] tzdata 2008h-2 -> 2008i-3
[UPGRADE] unattended-upgrades 0.25.1debian1-0.1 -> 0.37debian1
[UPGRADE] unrar 1:3.8.2-1 -> 1:3.8.5-1
[UPGRADE] vbetool 1.0-3 -> 1.1-2
[UPGRADE] x-ttcidfont-conf 31 -> 32
[UPGRADE] x11proto-input-dev 1.4.3-2 -> 1.4.4-1
[UPGRADE] xarchiver 0.4.6-8 -> 0.5.2+dfsg-2
[UPGRADE] xkb-data 1.3-2 -> 1.5-2
[UPGRADE] xterm 235-2 -> 241-1
[UPGRADE] xutils-dev 1:7.4+3 -> 1:7.4+4
[UPGRADE] zenmap 4.62-1 -> 4.68-1